Loading...

Java error when installing IBM InfoSphere Information Server

Error message:
Java error when installing IBM InfoSphere Information Server

Exception in thread "main" java.lang.UnsatisfiedLinkError: awt (An exception was pending after running JNI_OnLoad)
at java.lang.ClassLoader.loadLibraryWithPath(ClassLoader.java:1011)
at java.lang.ClassLoader.loadLibraryWithClassLoader(ClassLoader.java:975)
at java.lang.System.loadLibrary(System.java:469) at sun.security.action.LoadLibraryAction.run(LoadLibraryAction.java:69)
at java.security.AccessController.doPrivileged(AccessController.java:202)
at sun.awt.NativeLibLoader.loadLibraries(NativeLibLoader.java:50)
at sun.awt.DebugHelper.<clinit>(DebugHelper.java:29)
at java.lang.J9VMInternals.initializeImpl(Native Method)
at java.lang.J9VMInternals.initialize(J9VMInternals.java:200)
at java.awt.Component.<clinit>(Component.java:571)
at java.lang.J9VMInternals.initializeImpl(Native Method)
at java.lang.J9VMInternals.initialize(J9VMInternals.java:200)
at java.lang.J9VMInternals.initialize(J9VMInternals.java:167)
at java.lang.J9VMInternals.initialize(J9VMInternals.java:167)
at java.lang.J9VMInternals.initialize(J9VMInternals.java:167)
at java.lang.J9VMInternals.initialize(J9VMInternals.java:167)
at com.sterlingcommerce.cd.cdremoteagent.RAMain.myLocalHost(RAMain.java:1025)
at com.sterlingcommerce.cd.cdremoteagent.RAMain.main(RAMain.java:691)

Cause
The following libraries may be missing
libXtst-1.0.99.2-3.el6.i686
libXmu-1.0.5-1.el6.i686

Environment
IBM Sterling Connect: Direct 4.1 on Linux

Diagnosing the Problem
Find out what libraries are installed with the command: rpm -qa | grep -i compat-libstdc
Resolving the problem
LibX11 libraries are necessary to run Connect:Direct but they come with the Linux installation.
For Red Hat Enterprise Linux version 6, RH 6.2 the following libraries need to be installed

libXtst-1.0.99.2-3.el6.i686
libXmu-1.0.5-1.el6.i686
libXt-1.0.7-1.el6.i686
libXft-2.1.13-4.1.el6.i686
libX11-1.3-2.el6.i686
libXi-1.3-3.el6.i686
libXext-1.1-3.el6.i686
libXau-1.0.5-1.el6.i686
libXrender-0.9.5-1.el6.i686

For Linux zSeries Red Hat Advanced Server compat-libstdc++-33.3.2.3-47.3 (or later)
For Intel and AMD x86/x86-64, Linux zSeries All supported Linux libstdc++.so.5


Tip: You can acquire this library by applying the compat-libstdc++-33 package.
Training 2893650058550796858

Post a Comment

  1. This concept is a good way to enhance the knowledge.thanks for sharing. please keep it up Java online training

    ReplyDelete

emo-but-icon

Home item

Blog Archive

Popular Posts

Random Posts

Flickr Photo